Installing CallButler on a 64 bit system... can't do it.

Sep 23, 2010 at 11:09 PM

Hey there. I am running windows 7 64 bit. When I go to install it it tells me that i have to install the .NET framework. I go to do that, and then it tells me it isn't supported on a 64 bit system. I can't continue the install.

Any help? Thanks :P

Developer
Sep 24, 2010 at 3:48 AM

Try installing .NET 4 x64 from http://www.microsoft.com/downloads/en/details.aspx?FamilyID=0a391abd-25c1-4fc0-919f-b21f31ab88b7 and try again.

Sep 24, 2010 at 7:10 AM

Tried it. Still am getting the same message.

It doesn't detect that the .Net framework is already installed.

Thanks for your help, though. Any other suggestions?

Developer
Sep 24, 2010 at 6:12 PM

Not really, It seems the appropriate settings have not been done for the setup package and nobody seems to be continuing the project!

If I had access to the setup project it is a few minute fix. 

Sep 24, 2010 at 7:11 PM

Is there any way you can get access to it? Someone to contact?

I'd gladly go out of my way to try to make contact with them. It looks like a great program.

Developer
Sep 24, 2010 at 7:23 PM

I have sent emails to the appropriate people, Fingers Crossed :-)

Sep 24, 2010 at 7:29 PM

I sent a message to one of the coordinators. And by message I mean email. And by "coordinator" I mean someone who has the exact same screen name on another development site and posted it publicly there.

Fingers crossed as well :P

Sep 25, 2010 at 3:35 AM

Here's what I got as a reply:

 

Hey there. the CallButler installer is made with Advanced Installer.
Do you have that program available for use?

Cheers,
-jim

Developer
Sep 25, 2010 at 4:31 AM

Yes version 7.7

Sep 25, 2010 at 5:17 PM

ok I just sent him a message and told him. I will get back to you asap when he gets back to me.

Sep 26, 2010 at 10:58 PM

Ok. I got the .aip file. Where can I send it to you at, SpiderMaster?

Lemme know

Developer
Sep 28, 2010 at 4:52 AM

Click on my user link beside this comment and use the Contact user page as I would prefer not to post mailto's etc in a post.

Oct 25, 2010 at 8:03 AM

Hi,

i have the same problem on windows 7 64 bit.

i installed VMware player with XP. callbutler worked fine till windows update....

can you guys please send me the advanced install file?

 

Developer
Oct 25, 2010 at 6:18 PM

jbl39 never contacted me after my last reply nor did they return to codeplex so I do not know what is happening.

It is pretty sad to see such a great system be left in a non usable state!

Oct 25, 2010 at 10:30 PM

Hey, just let me know what you need. I am pretty sure I sent you the file. I'll send it again, perhaps.


check your spam folder or something to make sure.

Developer
Oct 26, 2010 at 12:44 AM

Got it, Thanks. Did not happen to get a 'Scripting Components.msm' (merge module) as well did you?

Will take a bit longer than expected, kinda hoped for a zipped solution but I will have to download the source and re link the files and re configure the setup.

The problem is not exactly the developers fault. What the problem is here is that you will have .NET 4.0 runtime installed and the installer will except that however you will have an updated version where the actual version is something like 4.1.3**.** and so on and the installer fails and exits!

The .aip file itself has been fixed up, just changed the version to 4 rather than 4.0 when verifying the file mscoree.dll.

The problem now is the missing file (possibly files) and re linking to the source files.

Oct 26, 2010 at 5:26 AM

I'll shoot an email off to the guy asking for the Scripting Components.msm.

I'll let you know as soon as I hear anything.

Oct 26, 2010 at 9:20 AM

Hey guys,

thanks for the reply.

yep, it is sad that this project is sleeping.

i am not a programer, and Trixbox is limited with its IVR....

So, if you have anything that can help me, i will appriciate it a lot.

thanks,

Developer
Jan 1, 2011 at 9:08 AM
Its been awhile and after purchasing some equipment I am getting keen to getting this all to work (and well)
So far everything installs fine with the old setup here in the downloads section so long as you do not install anything higher than .NET framework 4.0.0.0 (4.0.0.1 is enough to confuse the installer and fail) To do this you also need to disable windows automatic updates (and not manually use windows update at all) not very convenient but it is a work around until I can get a hold of the following files.
  • Known Files Needed to complete the Setup.
    • eula.rtf (not really needed but want to keep the original developers bits as they were)
    • Scripting Components.msm (and anything else this refrences)
    • CallButler User Manual.chm (I have none of the "Call Butler Open Source PBX\Documentation" Directory)
    • MSVCR70.DLL
    • office.dll
    • Microsoft.Office.Interop.Outlook.dll
    • 11111111-1111-1111-1111-111111111111.snd
    • 33333333-3333-3333-3333-333333333333.snd

If the Co-Ordinators could please forward the above files to me I would be happy to make a release that solves the .NET 4 bugs.

Apr 28, 2011 at 4:44 PM

What is the status on this?  I need the extensions.xml file does anyone have a version?

Developer
Jun 6, 2011 at 10:55 AM

Please check out this discussion

http://callbutler.codeplex.com/discussions/260232