I am getting error app on Server 2008

Dec 1, 2008 at 3:00 PM
I am trying to register following dlls on Windows Server 2008
NCTAudioCompress2.dll
NCTAudioFile2.dll
NCTAudioInformation2.dll
NCTAudioPlayer2.dll
NCTAudioRecord2.dll

and I'm getting errors.

I can't register these dll on Server 2008, but on Windows Server 2003 all is fine!
Because of this "CallButler Management" doesn't work correctly when doing things like editing extensions
How solve this probolem?

Sorry for my English!

Thanks in advance!

Dec 1, 2008 at 7:15 PM
Edited Dec 1, 2008 at 7:16 PM
Leony,

Are you on 64bit? Try using c:\Windows\syswow64\regsvr32.exe instead.

-alpha
Dec 2, 2008 at 6:55 AM
Thank you for your response!

No, I am on 32bit. :( , but I've tryed to do it on 64bit and get the same error. Maybe these dlls doesn't work under Server 2008?

Thanks in advance!

Dec 2, 2008 at 8:45 AM
Leony,

Yeah I do know that some people have had problems registering these DLLs in Vista and 2008. I might have to create a simple installer program for them. The installer extracts the DLL information itself and manually puts the resulting data in the system registry. Give me a few days to work something out for you.

-alpha
Dec 2, 2008 at 9:19 AM
Thank you a lot of quick response and thank you for this really awesome project!
Looking forward to hearing from you soon!
I wish you every success!

Dec 2, 2008 at 6:39 PM
Leony,

I just realized that you can get this resolved easily right away. Just install the downloadable binaries available in the Release section of this site. That installer will install all of the Dlls you'll need. Then after you install it, just Disable or set the the CallButler Service to Manual start.

-alpha
Dec 3, 2008 at 1:44 PM
I've just instaled binary version from Release section of this site and it's doesn't work correctly, I receive the same errors! :(


Dec 3, 2008 at 1:54 PM
Edited Dec 11, 2008 at 7:54 AM
Today I've downloaded your Commercial Version and install it. It works on Server 2008 perfectly, why "Open Source version doesn't work correctly"?

Thanks alpha in advance!




 
Dec 20, 2008 at 6:37 AM
Today, I've disabled DEP in Windows 2008 and now it works perfectly, but I can't record my voice.

Thanks a lot everyone who take party in creation this perfect project!