Transfer failed

Jan 14, 2009 at 7:06 PM
Whenever a call comes in, Callbutler is not successfully making the transfer. I was running version 1.9.13, upgraded to 1.9.14 and still had same issue.

Voip provider is CallCentric, and yes I do have an outbound line that works.  When the call is transferred, either to a IP phone or POTS line, I get the same result.  Callbutler makes the outgoing call, announces the caller, and then hangs up and goes to voicemail no matter what number is pressed.  Below is a log trace.  Note the "ERROR" about 2/3 of the way down.

[1/14/2009 12:05:47 PM] (Line 1) Incoming call from  14799032880 to 14792504778 ss.callcentric.com
[1/14/2009 12:05:47 PM] (Line 1) Call Connected
[1/14/2009 12:05:48 PM] (Line 1) Playing sound at C:\Program Files\CallButler Open Source PBX\Service\Sounds\Greetings\en\11111111-1111-1111-1111-111111111111.snd
[1/14/2009 12:05:52 PM] (Line 1) Heard a DTMF tone '1' (OOB)
[1/14/2009 12:05:53 PM] (Line 1) Heard a DTMF tone '0' (OOB)
[1/14/2009 12:05:53 PM] (Line 1) Heard a DTMF tone '3' (OOB)
[1/14/2009 12:05:55 PM] (Line 1) Transferring call to 103
[1/14/2009 12:05:56 PM] (Line 1) Playing sound at C:\Program Files\CallButler Open Source PBX\Service\Sounds\System\en\Find Extension.snd
[1/14/2009 12:05:56 PM] (Line 2) Making an outgoing call to 1 (479) 203-7175
[1/14/2009 12:06:00 PM] (Line 2) Call failed
486 - Busy here
[1/14/2009 12:06:00 PM] (Line 2) The call is finished but the line still appears to be locked. You may want to check the script to make sure it is exiting gracefully.
Locked: True
Script Is Running: True
Line In Use: False
Script: Extension Finder
[1/14/2009 12:06:01 PM] (Line 2) Making an outgoing call to 1 (479) 381-0549
[1/14/2009 12:06:04 PM] (Line 1) Finished playing sound
[1/14/2009 12:06:04 PM] (Line 1) Playing sound at C:\Program Files\CallButler Open Source PBX\Service\Music\For-Jehter-60sec.wav
[1/14/2009 12:06:11 PM] (Line 2) Call Connected
[1/14/2009 12:06:12 PM] (Line 2) Playing sound at C:\Program Files\CallButler Open Source PBX\Service\Sounds\System\en\Call from.snd
[1/14/2009 12:06:13 PM] (Line 2) Finished playing sound
[1/14/2009 12:06:13 PM] (Line 2) Speaking '<voice required="Name=ScanSoft Samantha_Full_22kHz">1 (479) 903-2880</voice>'
[1/14/2009 12:06:19 PM] (Line 2) Heard a DTMF tone '1' (OOB)
[1/14/2009 12:06:21 PM] **ERROR** (Line 1) Transfer failed
[1/14/2009 12:06:21 PM] (Line 2) Script finished processing
[1/14/2009 12:06:21 PM] (Line 2) Call Ended
[1/14/2009 12:06:21 PM] (Line 1) Playing sound at C:\Program Files\CallButler Open Source PBX\Service\Sounds\Greetings\en\00914a31-21ad-47bd-88e2-1748b9c91e2e.snd
[1/14/2009 12:06:22 PM] (Line 2) Script finished processing
[1/14/2009 12:06:30 PM] (Line 1) Call Ended
[1/14/2009 12:06:30 PM] (Line 1) Script finished processing
Jan 14, 2009 at 8:36 PM
sd can you send us a SIP trace file? Do you know how to do this?
Jan 14, 2009 at 8:40 PM
I just emailed the sip trace.
Jan 22, 2009 at 8:00 PM
i have the exact same problem
Jan 31, 2009 at 5:44 PM
Same with me. I will be great if someone can troubleshoot this problem Please.
Jan 31, 2009 at 8:38 PM
As much as this pains me to type this, I have finally gotten off of Callbutler & Teliax.  I have been a long time fan of callbutler and it's design.  At one point, the support for callbutler was great, but now that it has gone open source the support seems to be a casual occurrence.  Unfortunately, we can't rely on this product any longer to run our PBX.  As of now, I have switched over to a product called 3cx.  As long as you have under 10 extensions it is free.  It is a bit more cumbersome to configure, but hey, stability does have it's perks.  I have also jumped ship from Teliax and moved to Callcentric.  The combination of the two has left my customers a lot more enthusiastic.
Jan 31, 2009 at 10:02 PM
sdbeckwith, I was evaluating Callbutler - and must say that it had me completely excited to consider VOIP for my business again! 

I installed it, was excited... incoming calls worked practically right out of the box.  But i couldn't get support for making an outgoing call, so I started a thread.  2 Weeks with no replies... (http://www.codeplex.com/callbutler/Thread/View.aspx?ThreadId=44497) It is discouraging.  Since this product was at one tie commercial, you would think that maybe a 'troubleshooting guide' existed for the help center?  Maybe that would be available?  Regardless, I BOUGHT a line at teliax to troubleshoot!  So now you have me worried!

For now, I switched to a product called "Freeswitch."  I will continue to monitor for improvements to Callbutler, and wish the developers good luck!  Heck, I even put my money where my mouth is, and offered a donation to the project, but never received a reply there either.  of course, it could be me, I may just be missing something! I actually wonder if my posts are not visible to others?  http://www.codeplex.com/callbutler/Thread/View.aspx?ThreadId=44496.  

Good Luck Callbutler!


Jan 31, 2009 at 10:50 PM
robclay -
Let me first start off by saying this is a "free" program, support is free, and Alpha (developer) has given a product he worked on for a long time to the open source community.

Secondly, if you are technical enough to write the FreeSWITCH XML configs I believe that you would know also to post a SIP trace.  A message saying "blah blah" could first off be coming from your provider and second off could mean a number of things, so that really is only a beginners start.

I will be glad to provide as much assistance as I can with your problem, but without that SIP trace we will be trying to shoot fish in the ocean.

On a furthernote FreeSWITCH is just what it's name implies a switch not a PBX.  It is missing many core features of a successful PBX and it is not the long-term goal of the project, but I can admit there are modules available that add most PBX functionality it is still not ready for non phone company use.
Feb 1, 2009 at 2:37 AM
starwarp...

I would love to keep trying Callbutler - I just thought my problem had not been encountered before, and I was trying to list every step I had taken in an effort to help others.  My troubleshooting skills are obviously lacking with VOIP! (hence why I didn't know to post a SIP trace, but I did see on THIS thread, Alpha asked for one.  So I figured for my request, a SIP trace was not going to help.  Again, it is a problem with my understanding of the way all of this works, and what is needed to help troubleshoot!)  But that makes sense.  I think the instructions on running a SIP trace are listed on the site.  (I am pretty sure I have seen the instructions posted. But if you know of an easy link I would be most obliged.  Maybe I saw the instructions in the help file.)

Lastly - And this may further show my ignorance, what is the difference between a switch and a PBX?

As for the "free" part, is it considered in poor taste to donate?  i.e. I know some freeware has an 'If you like this product, please donate.' but I don't think I saw that on the callbutler site.

Thanks,
Robert

PS - Hope to take you up on the support!  :)











Feb 1, 2009 at 3:55 AM
From a post of Mikey's:

To run a SIP trace
  • In Windows, click Start > All Programs > CallButler > Utilities > Start CallButler in Debug Mode.  After a moment you should see a new CallButler icon on the bottom right of the screen.
  • Right-click this new icon.
  • Click Options > Show SIP Diagnostics. A new window will pop-up called “Visual SIP Tracing”.
  • Reproduce the connection or call issue.
  • In the “Visual SIP Tracing” window, click File > Save Trace File.
  • In the Save Trace File dialog box, select “XML Trace File (*.xml)” in the “Save as type” dropdown box.
  • Give the file a name and save it to your computer.
  • Open the file with Notepad or Wordpad.  Use "Find" to look for the expression "INVITE sip".  You should see what is happening with the call from there.

Also, thanks for not taking offense as that was not my intention.  After rereading the post I apologize for coming off obnoxious.

Please post the sip trace on your orignial thread so we stop hijacking this one.

Also, a switch is a call "router" takes Input A and puts it to Output A or whatever the case may be.  Imagine the olden days where an operator had to plug a cable into the caller and callees ends to connect them.  Now imagine a PBX as a receptionist, the receptionist can transfer, put on hold, answer basic questions, route calls, queue calls, etc.  Freeswitch does have many of these features, but there primary focus is stability and call volume both of which interfere with a bunch of bloated "features."

Donations would most likely be directed towards Alpha.  So I cannot answer that question.

I am in no way an expert of callbutler especially the recent code changes Alpha made, but I am preety familiar with the general workings of the SIP protocol.  I am not guaranteeing anything, but I will try.

Feb 1, 2009 at 8:33 AM
All,

I'm really very sorry that everyone is having problems with call transfers. For those of you who are having issues, can you please tell me if the "Hand off call transfers" option is checked for the extension you're using? If so, does turning it off make it better?

-alpha
Feb 7, 2009 at 9:19 PM
Anyone?
Feb 18, 2009 at 1:17 AM
I have hand off call transfer unchecked because I was told originally to uncheck this box  to fix the problem in the old version of call butler. In the old version if you had hand off call transfer checked  it would drop the call automatically... So  I  dont check and it drops all call
Feb 19, 2009 at 11:59 PM
So it is unchecked and you're still getting transfer problems?
Feb 23, 2009 at 10:55 PM
Okay I have had similar issues with outbound calls not working. I post this information to help any programmer out there to fix what the issues are. I love this program and would hate to start useing a diffrent one.

Here is what I have done:
1. I installed the new release on my laptop and when I connect to the internet with no firewalls or routers at all it works perfect.
2. I installed this on a dedicated computer to run this software, unlocked all firewalls and no antivirus on this computer. The router had port 5060, 5070 and many others point to this computer. Callbutler recives calls fine but will not transfer out at all.
3. I installed the commercial release on this dedicated computer and it works perfectly? So the problum has to be in the open source releases ( both do not work, can not call out ).

I hope this helps out, Again I am runniogn the Comercial release and it is workign fine but the open Source realease do not work behind a firewall but works fine when internet it is not connected to a router or firewall.
Feb 25, 2009 at 3:53 PM
I have been trying hard to get this to work and have installed and uninstalled the three versions several times over. At one point the open source program worked perfect and was able to transfer to my ip phone and call out. Now I am running the open source new release and call out works fine but will not transfer to my ip phone.
I have installed and unistalled the program many times and I have set it up the same each time. I have made no changes to my firewall or any other harware setting. I am not sure what is going on why it did not work, why it worked for a second and why it only works a little now. But appearent installing and unistalling the commercial release did somthing to make it work?
Mar 7, 2009 at 10:18 PM
alpha it doesnt matter whether hand off  is checkd on unchecked it still has the same problem
Apr 3, 2009 at 2:49 AM
I would appreciate any help.  I can't get it to work and I paid for my copy until the release.  I can't the script editor to work, or for the script to transfer.

AHHHH
May 5, 2009 at 3:56 AM
Hi,

Hate to add to the thread, and hope for a reply.  Transfer works fine as a bridged call from the script, but any reason why on the bridged call, it can't recognize my key presses?  Also, is there a way to transfer the call with the caller id of the original caller?