YES Call butler will install on Vista

Mar 19, 2009 at 4:29 PM
Edited Mar 19, 2009 at 4:37 PM
Call butler will work on vista. Need net framework 2.0 and very important to update service pack. (from www.download.com)
I have vonage softphone and callcentric. Both works fine.
Mikec2